Insights & Ideas

Security Update: OpenSSL and Rosslyn Analytics

There have been a number of stories in the press recently regarding the security flaw identified in OpenSSL (CVE-2014-0160), and the breadth of systems that it has compromised as a result.

We wanted to take this opportunity to reassure you about the safety and security of the Rosslyn RAPid platform.

At Rosslyn Analytics, we have developed our own extension of a proprietary TLS security implementation for the RAPid platform, and we wanted to confirm that the OpenSSL security flaw has no effect on our platform or your data. This implementation features a number of industry-leading security standards and protocols including two-factor authentication and X.509 PKI.

We pride ourselves on the strength of our security and place a huge emphasis on continually evolving our security protocols to ensure protection against bugs such as this.

This approach to security and protection of RAPid will continue as we aim to provide the most resilient and secure data management and analytics platform available for our clients.

 

Our clients